Speedmaster radiator fan fixing

Note: The contents of this post first appeared in ‘What You Been Doing With Your Triumph Today
Following this will be new posts in the saga.

On way home from holiday I had engine temperature warning light come on whilst stuck in traffic, so I resorted to killing engine at stops until on open road where things seemed fine. Sure enough, when home found fan wasn’t coming on, so today I set about investigating.

Following trusty Haynes manual I first checked the fuse, which was fine, then got at connector under tank, but not having handy cables I thought that instead of putting 12V from battery onto fan wire to test it, I’d be easier to get TuneECU to do fan test and look at voltage with multimeter. Sure enough, I could hear relay click and 12V appear on connector so decided problem was with fan, bugger, a new one costs £250.

Even more of a problem was actually getting at fan, I could unbolt it easily (thankfully no rusted fasteners) but to get it out I would have to take radiator off. So I drained the coolant system and tried wrestling it out. Not meeting success I resorted to subscribing to Triumph service manual to see what the ‘correct’ procedure was. Found out that was to remove the engine cradle, the same cradle which I had jack under supporting bike. :frowning:

In the end I resorted to sacrificing blood from my knuckles whilst using three small screwdrivers like mini tyre irons to get coolant hose off engine. Only then with radiator and fan off I decided to double check it by connecting up to battery, and the fan worked! And to add to my stupidity, I had fan resting on seat and the blades put a slash in the coccyx cushion. (I have a spare for an old seat fortunately).

So, it seems like fan problem is a high resistance in the wiring or relay which are probably very inaccessible, so it’s time for a stiff drink and return to this tomorrow…

Forks are out, because I’d decided to referb them and do headstock bearings. Also on the list to do is chain and sprockets as the 1000 mile holiday had produced 20mm extra slack so chain must buggered (done 25k miles so not too bad).

The next day…

More bike dismantling…

Service manual also said to get battery compartment lid off, which was rather daunting being as there’s 7 sets of wires and connectors intertwined with it in various ways. As I started to untangle that I was thinking that I’d never get it back together no matter how many photo’s I took. However, it looked to me like the battery holder would come out without the lid so I checked Haynes manual and it implied it did, phew! Finally, after 2 hours I had sight of the relays, though only fingertip access in bowels of bike.

Think I found my radiator fan problem…

I’ve ordered a new relay but was worried how to clean up the socket.

Would love to spray in some solvent cleaner in, but all around there is ECU, regulator and ABS modulator, plus other relays which might not like that. So decided to just spray in some soapy water and use a toothbrush (about all I could get into the space). Relays seem to have dialectic grease on contacts so there’s probably muck stuck in the relay socket but I don’t know what I can do about that. Decided to just clean up old relay pins and put back in and out a couple of times to try and dislodge any crap.

Have ordered 3 new relays, as was thinking of a preventative replacement of the neighbours, but the wire bundle there is stiff and short and goes into an inaccessible connector (to the ECU I think). Will probably leave well alone

1 Like

When relays arrived I compared them to the old one and had an ‘oh shit’ moment…

So there’s a pin broken of inside inaccessible socket, bugger!

I knew I would need to try and improve access so I did the things I was reluctant to do earlier. First force aside the stiff bundle of wires which went to the ABS unit out the way, cringing as the connector to the unit twisted and praying nothing got damaged. Then to tackle the nest of wires and connectors on the battery box lid, taking copious photo so I would know how to reassemble.

I ended up butchering some connectors slightly to get them apart, because when even pressing the right release clips they wouldn’t separate without lots of force. They are all of a completely different design and one had clips on three sides for a 2 pin connector (why?) and one looked like a cloverleaf plug which pliers couldn’t grip properly due to it’s shape and it’s now distorted (not the bit that mates together though, so should be OK).

This work gave me more access, but the socket I was interested in wasn’t accessible directly from above. It’s actually to the right of the empty socket you can see in this photo.

I had a bit of a brainstorming session with a friend, most of which were infeasible or dangerous. What I did try was to test the depth of an empty connector to see if pushing broken pin through could work (it couldn’t) then I had what I thought was a clever idea, I could push a hook into the connector and get under the pin an pull it out. So onto Amazon to find something likely looking for next day delivery.

Meanwhile, as new chain and sprockets had arrived I got on with that job.

Next day the hooks arrived.

On modifying one of these I found I could get access how I’d hoped, however the metal was a bit too soft for the force needed and I began to think that even with the perfect tool, this approach probably wouldn’t work.

Now, when doing the sprocket change the previous day, I had come across a plastic cover that would give me some access from the other side, so I decided to try this, on the principle that more access = more options.

Behind there was evap system components (which I cleaned up).

In that picture the red plastic boot is on the starter solenoid, to the left of that is the rollover valve, below which is the purge valve, and below again the evap canister. That is held on with cableties and when pushed aside gives access, just, to the bolt under the purge valve, which then when unscrewed could be pushed aside too. The rollover valve is just a plastic clip which can be popper out the frame and finally, there be relays! (Cleaned up with contact cleaner spray).

Now this didn’t get me much better access to getting pin out but I could see and feel that the block of 4 relay sockets was just held in place on the left (towards bike rear) and the wires came from the right. So if I could release the block it would pivot out and be totally accessible :slight_smile: I definitely felt like there was and end in sight.

It looked like the connectors were just pushed onto a plastic pillar which was part of the base plate but it didn’t want to simply pull off, so I managed to thread a screwdriver down past other internals to try pushing it into what I thought was the correct place to release a clip. After a pit of prodding and pulling it came free. I now had connectors in my palm and access to the underside :smiley:

Will need to get connector out of block to fish out broken pin, but that will have to wait until another day as my back killing me from crouching over bike all day. It feels like a time for a celebratory beer.

1 Like

Returning to this today I found it easy to pull out broken pin with pliers :slight_smile: , here’s the source of all my woes.


To check I hadn’t messed up any of the electrics this past week, I temporarily fitted new relays in the accessible position and reconnected everything I’d disconnected other side. Then came the time to try turning bike on and seeing if things were working. They weren’t, it was complete dead! :open_mouth: After a mild panic, I thought to connect the live wire going to starter solenoid which I’d missed off thinking I wouldn’t need it. This time things sprang to life. Hurray! Lights and instruments seemed to work and TuneECU showed no engine faults, and importantly, running fan test spun the fan (this time resting safely on some wood, not my seat).

Think it’s about time I started reassembling things!

First thing to reassemble properly would be the radiator and fan. Getting coolant hose onto engine was very awkward, using the tips of screwdrivers to poke it on after lubricating things with some coolant. But then I got struck trying to get clip on as couldn’t get purchase with any pliers.

Triumph service manual says to remove O2 sensor, but didn’t want to risk that, in case thread was seised after 40k miles of running. Instead I decided to go to Amazon to buy a tool for the job, due to arrive tomorrow…


Good progress mate. You will be riding in no time now :grinning:

Thanks :slight_smile: Still got new head bearings, new chain and other things to do, might as well whilst bike in pieces :wink: but definitely want to get some things together before taking more things apart. Currently I’m scouring parts diagrams trying to work out where an 8mm M5 button head bolt lives, it’s going spare on my bench and don’t want to put too much together before I know where it lives…

Edit: Found it, purge valve mounting screw, phew, can sleep well tonight :slight_smile:


Got radiator hose fitted, thanks to Amazon delivering the right tool for the job (hose clamp pliers)…

That handle has been cut to get it in.

Still fiddly as ratchet is coarse and couldn’t get clamp fully loose, but some prodding and cursing got it fitted.

Then I fitted relays properly with dielectric grease on all contacts - the originals were too but obviously factory missed a bit hence corroded and broken pin. Fitting all the electrical connectors and the battery box was a struggle, but after more than an hour got that in and tested bike as good as I can without starting engine. No error codes, the fan worked and instruments and lights worked, except, number plate light :frowning: Bugger, that’s on one of those fiddly connectors, so perhaps I broke a wire? Or perhaps it was like that before and I didn’t notice. MOT due this month, so need to fix it before then. Anyway, fan now works, so that’s it for this thread.

Edit: Number plate light was faulty.


They look handy!

A very informative and good read mate, I have enjoyed watching your progress. :grinning:

I love these sorts of “real world” problem sorting threads!

Well done… I was going to suggest turning the bike upside down and shaking it, see if that crroded tab just falls out - but you got it sorted anyway!

Meanwhile…“hose clamp pliers”…I don’t know if I am excited by the prospect of a new tool, or irritated that something else requires “yet another specific bloody tool”!


Exactly why we have this bit of the workshop! There’s a ton of knowledge locked up in members’ noggins. Let’s get all that good stuff out there for others to lap up. :slight_smile:

1 Like